<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.technewstoday.com/xmlrpc.php" />
<script type="text/javascript"> var jnews_ajax_url = 'https://www.technewstoday.com/?ajax-request=jnews'; </script>

<title>8 Best Portable PC Cases with Handles in 2020</title>
<meta name="description" content="Packing up for a LAN party or a gaming event can be quite a challenge if you don’t own a Portable PC Case. Here are the best portable cases with handles" />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.technewstoday.com/best-portable-pc-cases-with-handles/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="8 Best Portable PC Cases with Handles in 2020" />
<meta property="og:description" content="Packing up for a LAN party or a gaming event can be quite a challenge if you don’t own a Portable PC Case. Here are the best portable cases with handles" />
<meta property="og:url" content="https://www.technewstoday.com/best-portable-pc-cases-with-handles/" />
<meta property="og:site_name" content="Latest Tech News Today, Reviews &amp; Guides" />
<meta property="article:published_time" content="2020-07-20T13:13:04+00:00" />
<meta property="article:modified_time" content="2020-07-20T15:06:04+00:00" />
<meta property="og:image" content="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="600" />
<meta name="twitter:card" content="summary_large_image" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.technewstoday.com/#website","url":"https://www.technewstoday.com/","name":"Latest Tech News Today, Reviews &amp; Guides","description":"","potentialAction":[{"@type":"SearchAction","target":"https://www.technewstoday.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.technewstoday.com/best-portable-pc-cases-with-handles/#primaryimage","inLanguage":"en-US","url":"https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle.jpg","width":1200,"height":600,"caption":"Best Portable PC Cases With Handle"},{"@type":"WebPage","@id":"https://www.technewstoday.com/best-portable-pc-cases-with-handles/#webpage","url":"https://www.technewstoday.com/best-portable-pc-cases-with-handles/","name":"8 Best Portable PC Cases with Handles in 2020","isPartOf":{"@id":"https://www.technewstoday.com/#website"},"primaryImageOfPage":{"@id":"https://www.technewstoday.com/best-portable-pc-cases-with-handles/#primaryimage"},"datePublished":"2020-07-20T13:13:04+00:00","dateModified":"2020-07-20T15:06:04+00:00","author":{"@id":"https://www.technewstoday.com/#/schema/person/0cf2a0f7a9fed7697f946bf2a30f0133"},"description":"Packing up for a LAN party or a gaming event can be quite a challenge if you don\u2019t own a Portable PC Case. Here are the best portable cases with handles","breadcrumb":{"@id":"https://www.technewstoday.com/best-portable-pc-cases-with-handles/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.technewstoday.com/best-portable-pc-cases-with-handles/"]}]},{"@type":"BreadcrumbList","@id":"https://www.technewstoday.com/best-portable-pc-cases-with-handles/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.technewstoday.com/","url":"https://www.technewstoday.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.technewstoday.com/buyers-guide/","url":"https://www.technewstoday.com/buyers-guide/","name":"Buyer's Guide"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://www.technewstoday.com/tag/computer-cases/","url":"https://www.technewstoday.com/tag/computer-cases/","name":"Computer Cases"}}]},{"@type":["Person"],"@id":"https://www.technewstoday.com/#/schema/person/0cf2a0f7a9fed7697f946bf2a30f0133","name":"Tech News Today","image":{"@type":"ImageObject","@id":"https://www.technewstoday.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/25b6cfe7eee2110cb2bc994a0aecb48f?s=96&d=mm&r=g","caption":"Tech News Today"}}]}</script>

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Latest Tech News Today, Reviews &amp; Guides &raquo; Feed" href="https://www.technewstoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Latest Tech News Today, Reviews &amp; Guides &raquo; Comments Feed" href="https://www.technewstoday.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Latest Tech News Today, Reviews &amp; Guides &raquo; 8 Best Portable PC Cases with Handles in 2020 Comments Feed" href="https://www.technewstoday.com/best-portable-pc-cases-with-handles/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.technewstoday.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.technewstoday.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='quads-style-css-css' href='https://www.technewstoday.com/wp-content/plugins/quick-adsense-reloaded/includes/gutenberg/dist/blocks.style.build.css?ver=2.0.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-css' href='https://www.technewstoday.com/wp-content/plugins/jnews-gallery/assets/css/previewslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-responsive-css' href='https://www.technewstoday.com/wp-content/plugins/jnews-gallery/assets/css/previewslider-responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-parent-style-css' href='https://www.technewstoday.com/wp-content/themes/tnt/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='jeg_customizer_font-css' href='//fonts.googleapis.com/css?family=Khula%3Areguler%7COpen+Sans%3Aregular%2C600%2C700&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.technewstoday.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9.2' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='vc_lte_ie9-css'  href='https://www.technewstoday.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.5' type='text/css' media='screen' />
<![endif]-->
<link rel='stylesheet' id='mediaelement-css' href='https://www.technewstoday.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.13-9993131' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://www.technewstoday.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-frontend-css' href='https://www.technewstoday.com/wp-content/themes/tnt/assets/dist/frontend.min.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css' href='https://www.technewstoday.com/wp-content/themes/tnt-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-darkmode-css' href='https://www.technewstoday.com/wp-content/themes/tnt/assets/css/darkmode.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-scheme-css' href='https://www.technewstoday.com/wp-content/themes/tnt/data/import/tech/scheme.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.technewstoday.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-social-login-style-css' href='https://www.technewstoday.com/wp-content/plugins/jnews-social-login/assets/css/plugin.css?ver=5.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-select-share-css' href='https://www.technewstoday.com/wp-content/plugins/jnews-social-share/assets/css/plugin.css' type='text/css' media='all' />
<style id='quads-styles-inline-css' type='text/css'>
.quads-ad-label { font-size: 12px; text-align: center; color: #333;}
</style>
<script type='text/javascript' src='https://www.technewstoday.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-content/plugins/jnews-gallery/assets/js/jquery.previewslider.js'></script>
<link rel='https://api.w.org/' href='https://www.technewstoday.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.technewstoday.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.technewstoday.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://wp.me/pahqq9-59J' />
<link rel="alternate" type="application/json+oembed" href="https://www.technewstoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.technewstoday.com%2Fbest-portable-pc-cases-with-handles%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.technewstoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.technewstoday.com%2Fbest-portable-pc-cases-with-handles%2F&#038;format=xml" />
<script type='text/javascript'>document.cookie = 'quads_browser_width='+screen.width;</script>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/www.technewstoday.com\/#organization","url":"https:\/\/www.technewstoday.com\/","name":"","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/www.facebook.com\/TechNewsTodayTeam\/","https:\/\/twitter.com\/TNT_dotcom","http:\/\/www.pinterest.com\/TNT_dotcom\/"]}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/www.technewstoday.com\/#website","url":"https:\/\/www.technewstoday.com\/","name":"","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.technewstoday.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="icon" href="https://www.technewstoday.com/wp-content/uploads/2020/07/cropped-fav-icon-512x512-1-2-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.technewstoday.com/wp-content/uploads/2020/07/cropped-fav-icon-512x512-1-2-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.technewstoday.com/wp-content/uploads/2020/07/cropped-fav-icon-512x512-1-2-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.technewstoday.com/wp-content/uploads/2020/07/cropped-fav-icon-512x512-1-2-270x270.png" />
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail{display: none;}</style> <link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://www.technewstoday.com/?custom-css=8ff9ca75c5" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="post-template-default single single-post postid-19823 single-format-standard jeg_single_tpl_3 jeg_single_fullwidth jeg_single_narrow jnews jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive">
<div class="jeg_ad jeg_ad_top jnews_header_top_ads">
<div class='ads-wrapper  '></div> </div>

<div class="jeg_viewport">
<div class="jeg_header_wrapper">
<div class="jeg_header_instagram_wrapper">
</div>

<div class="jeg_header normal">
<div class="jeg_topbar jeg_container dark">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left  jeg_nav_grow">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_logo jeg_desktop_logo">
<div class="site-title">
<a href="https://www.technewstoday.com/" style="padding: 0 0 0 0;">
<img class='jeg_logo_img' src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" alt="Latest Tech News, Product Reviews &amp; Buyer&#039;s Guide" data-light-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-light-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" data-dark-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-dark-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x"> </a>
</div>
</div><div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_4" data-animation="animate"><li id="menu-item-12076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12076 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/news/">News</a></li>
<li id="menu-item-12077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12077 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/reviews/">Reviews</a></li>
<li id="menu-item-12078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12078 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/how-to/">How To</a></li>
<li id="menu-item-12079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12079 bgnav" data-item-row="default"><a href="#">Hardware</a>
<ul class="sub-menu">
<li id="menu-item-12083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12083 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/cpus/">CPUs</a></li>
<li id="menu-item-12080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12080 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/computer-cases/">Computer Cases</a></li>
<li id="menu-item-12081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12081 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/motherboards/">Motherboards</a></li>
<li id="menu-item-12082" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12082 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/ram/">RAM</a></li>
<li id="menu-item-12084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12084 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/gpu/">GPU</a></li>
<li id="menu-item-12085" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12085 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/psu/">PSU</a></li>
<li id="menu-item-12086" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12086 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/ssd/">SSD</a></li>
<li id="menu-item-19246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19246 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/fans-cooling/">Fans &#038; Cooling</a></li>
</ul>
</li>
<li id="menu-item-12087" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12087 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/gadgets/">Gadgets</a></li>
<li id="menu-item-12088" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12088 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/laptops/">Laptops</a></li>
<li id="menu-item-12089" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12089 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/gaming/">Gaming</a></li>
</ul></div></div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_center  jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
</div>
</div>
<div class="jeg_nav_col jeg_nav_right  jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">

<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.technewstoday.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div><div class="jeg_separator separator5"></div> <div class="jeg_nav_item socials_widget jeg_social_icon_block circle">
<a href="https://www.facebook.com/TechNewsTodayTeam/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/TNT_dotcom" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.pinterest.com/TNT_dotcom/" target='_blank' class="jeg_pinterest"><i class="fa fa-pinterest"></i> </a> </div>
</div>
</div>
</div>
</div>
</div></div> </div>
<div class="jeg_header_sticky">
</div>
<div class="jeg_navbar_mobile_wrapper">
<div class="jeg_navbar_mobile" data-mode="scroll">
<div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item">
<a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
<div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_mobile_logo">
<div class="site-title">
<a href="https://www.technewstoday.com/">
<img class='jeg_logo_img' src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" alt="Latest Tech News Today, Reviews &amp; Guides" data-light-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-light-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" data-dark-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-dark-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x"> </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.technewstoday.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div> </div> <div class="post-wrapper">
<div class="post-wrap">
<div class="jeg_main jeg_sidebar_none">
<div class="jeg_container">
<div class="jeg_content jeg_singlepage">
<div class="container">
<div class="jeg_ad jeg_article_top jnews_article_top_ads">
<div class='ads-wrapper  '></div> </div>
<div class="row">
<div class="col-md-12">
<div class="jeg_breadcrumb_container jeg_breadcrumbs">
<p id="breadcrumbs"><span><span><a href="https://www.technewstoday.com/">Home</a> » <span><a href="https://www.technewstoday.com/buyers-guide/">Buyer's Guide</a> » <span class="breadcrumb_last" aria-current="page">Computer Cases</span></span></span></span></p> </div>
<div class="entry-header">
<h1 class="jeg_post_title">8 Best Portable PC Cases with Handles in 2020</h1>
<div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1">
<div class="meta_left">
<div class="jeg_meta_author">
<img alt='Tech News Today' src='https://secure.gravatar.com/avatar/25b6cfe7eee2110cb2bc994a0aecb48f?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/25b6cfe7eee2110cb2bc994a0aecb48f?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /> <span class="meta_text">by</span>
<a href="https://www.technewstoday.com/author/ttnteam/">Tech News Today</a> </div>
<div class="jeg_meta_date">
<a href="https://www.technewstoday.com/best-portable-pc-cases-with-handles/">July 20, 2020</a>
</div>
<div class="jeg_meta_category">
<span><span class="meta_text">in</span>
<a href="https://www.technewstoday.com/buyers-guide/" rel="category tag">Buyer's Guide</a> </span>
</div>
</div>
<div class="meta_right">
</div>
</div>
</div>
</div>
<div class="jeg_featured featured_image"><div class="thumbnail-container animate-lazy" style="padding-bottom:50%"><img width="1140" height="570" src="https://www.technewstoday.com/wp-content/themes/tnt/assets/img/jeg-empty.png" class="attachment-jnews-1140x570 size-jnews-1140x570 lazyload wp-post-image" alt="Best Portable PC Cases With Handle" data-src="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle-1140x570.jpg" data-sizes="auto" data-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle-1140x570.jpg 1140w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle-300x150.jpg 300w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle-1024x512.jpg 1024w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle-768x384.jpg 768w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle-360x180.jpg 360w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle-750x375.jpg 750w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle.jpg 1200w" data-expand="700" /></div></div>
<div class="jeg_share_top_container"></div>
</div>
</div>
<div class="row">
<div class="jeg_main_content col-md-no-sidebar-narrow">
<div class="jeg_inner_content">
<div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
<div class="entry-content with-share">
<div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome">
<div class="jeg_share_float_container"><div class="jeg_sharelist">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.technewstoday.com%2Fbest-portable-pc-cases-with-handles%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=8+Best+Portable+PC+Cases+with+Handles+in+2020&url=https%3A%2F%2Fwww.technewstoday.com%2Fbest-portable-pc-cases-with-handles%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a>
<div class="share-secondary">
<a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.technewstoday.com%2Fbest-portable-pc-cases-with-handles%2F&title=8+Best+Portable+PC+Cases+with+Handles+in+2020" rel='nofollow' class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fwww.technewstoday.com%2Fbest-portable-pc-cases-with-handles%2F&media=https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Portable-PC-Cases-With-Handle.jpg&description=8+Best+Portable+PC+Cases+with+Handles+in+2020" rel='nofollow' class="jeg_btn-pinterest "><i class="fa fa-pinterest"></i></a>
</div>
<a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
</div></div> </div>
<div class="content-inner ">
<p>Packing up for a LAN party or a gaming event can be quite a challenge if you don’t own a Portable PC Case. With this understanding, we went out to find the best Computer Case with handle for LAN parties.</p>
<p>If you’ve never had to show off your gaming equipment outside your house then you seriously need to attend a LAN party. For such events, a computer/gaming rig can be difficult to move around because they’re usually bulky and rarely come with carry handles. That’s why a perfect case for a LAN party should at least have a handle, be compact, and come as lightweight as possible.</p>
<p>With portability as the ultimate spec we looked out for, here are the best computer cases with handle in 2020.</p>
<h2 class="toch2">Best Computer Cases With Handle</h2>
<table id="tablepress-37" class="tablepress tablepress-id-37">
<thead>
<tr class="row-1 odd">
<th class="column-1">Best Portable PC Cases With Handle</th><th class="column-2">Design</th><th class="column-3">Model</th><th class="column-4">Weight</th><th class="column-5">&nbsp;</th>
</tr>
</thead>
<tbody class="row-hover">
<tr class="row-2 even">
<td class="column-1">Most Portable PC Case</td><td class="column-2"><img src="https://www.technewstoday.com/wp-content/uploads/2018/12/Silverstone-ML08B-H-mITX-Case-with-Briefcase-Profile-1.jpg" alt="Silverstone ML08zB-H" width="150" height="150" class="aligncenter size-full wp-image-19396" /></td><td class="column-3">Silverstone ML08zB-H</td><td class="column-4">9.48 lbs</td><td class="column-5"><a href="https://www.amazon.com/SilverStone-Technology-Mini-ITX-Computer-ML08B-H/dp/B0161UXWRA/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US" rel="nofollow noopener noreferrer" target="_blank">Check Price</a></td>
</tr>
<tr class="row-3 odd">
<td class="column-1">Portable Computer Case With Handle</td><td class="column-2"><img src="https://www.technewstoday.com/wp-content/uploads/2018/12/BitFenix-Prodigy-M-Micro-ATX-Case-Double-Handles.jpg" alt="BitFenix Prodigy M" width="150" height="150" class="aligncenter size-full wp-image-19396" /></td><td class="column-3">BitFenix Prodigy M</td><td class="column-4">16 lbs</td><td class="column-5"><a href="https://www.amazon.com/dp/B00GVAQ2T6/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US" rel="nofollow noopener noreferrer" target="_blank">Check Price</a></td>
</tr>
<tr class="row-4 even">
<td class="column-1">Mini ITX Case With Handle</td><td class="column-2"><img src="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Mini-ITX-portable-gaming-case-Lian-Li-TU150WX.jpg" alt="Lian Li TU150WX" width="150" height="150" class="aligncenter size-full wp-image-19396" /></td><td class="column-3">Lian Li TU150WX</td><td class="column-4">11.7 lbs</td><td class="column-5"><a href="https://www.amazon.com/Razer-Coffee-8-Core-i9-9900K-3-6GHz/dp/B07R69SWHY/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US" rel="nofollow noopener noreferrer" target="_blank">Check Price</a></td>
</tr>
<tr class="row-5 odd">
<td class="column-1">Best Portable ATX Case</td><td class="column-2"><img src="https://www.technewstoday.com/wp-content/uploads/2018/12/Cougar-Panzer-Max-Ultimate.jpg" alt="Panzer Max Ultimate" width="150" height="150" class="aligncenter size-full wp-image-19396" /></td><td class="column-3">Panzer Max Ultimate</td><td class="column-4">8.82 lbs</td><td class="column-5"><a href="https://www.amazon.com/Cougar-Panzer-Max-Ultimate-Gaming/dp/B01HQHQF1W/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US" rel="nofollow noopener noreferrer" target="_blank">Check Price</a></td>
</tr>
<tr class="row-6 even">
<td class="column-1">Micro-ATX Case With Handle</td><td class="column-2"><img src="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Budget-Case-with-a-Handle-Cooler-Master-Q300P.jpg" alt="Cooler Master Q300P" width="150" height="150" class="aligncenter size-full wp-image-19396" /></td><td class="column-3">Cooler Master Q300P</td><td class="column-4">13.2 lbs</td><td class="column-5"><a href="https://www.amazon.com/Cooler-Master-Transparent-Adjustable-Controller/dp/B077XM396G/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US" rel="nofollow noopener noreferrer" target="_blank">Check Price</a></td>
</tr>
<tr class="row-7 odd">
<td class="column-1">Best PC Cases With Handle</td><td class="column-2"><img src="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-case-for-airflow-IN-WIN-D-Frame.jpg" alt="IN WIN D-Frame " width="150" height="150" class="aligncenter size-full wp-image-19396" /></td><td class="column-3">IN WIN D-Frame </td><td class="column-4">49.5 lbs</td><td class="column-5"><a href="https://www.amazon.com/D-Frame-2-0-WH-BL-Motorcycle/dp/B06XGNLGJM/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US" rel="nofollow noopener noreferrer" target="_blank">Check Price</a></td>
</tr>
<tr class="row-8 even">
<td class="column-1">Portable Modular Computer Case</td><td class="column-2"><img src="https://www.technewstoday.com/wp-content/uploads/2018/12/MasterCase-MC500Mt-Beautiful-Mid-Tower-Case-Designed-for-Durability-and-Portability.jpg" alt="MasterCase MC500Mt" width="150" height="150" class="aligncenter size-full wp-image-19396" /></td><td class="column-3">MasterCase MC500Mt</td><td class="column-4">37.55 lbs</td><td class="column-5"><a href="https://www.amazon.com/Cooler-Master-MasterCase-ATX-Mid-Tower-Management/dp/B078BC3F22/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US" rel="nofollow noopener noreferrer" target="_blank">Check Price</a></td>
</tr>
<tr class="row-9 odd">
<td class="column-1">Portable Desktop Gaming Case</td><td class="column-2"><img src="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-High-End-gaming-pc-case-ASUS-TUF-Gaming-GT501.jpg" alt="ASUS TUF Gaming GT501" width="150" height="150" class="aligncenter size-full wp-image-19396" /></td><td class="column-3">ASUS TUF Gaming GT501</td><td class="column-4">26.2 lbs</td><td class="column-5"><a href="https://www.amazon.com/ASUS-GT501-Mid-Tower-Motherboards-GRY/dp/B07L6CHS16/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US" rel="nofollow noopener noreferrer" target="_blank">Check Price</a></td>
</tr>
</tbody>
</table>

<p>If you want to quickly look at each of these in more detail, here’s a summary:</p>
<h2>Most Portable PC Case &#8211; <a href="https://www.amazon.com/SilverStone-Technology-Mini-ITX-Computer-ML08B-H/dp/B0161UXWRA/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US" target="_blank" rel="noopener noreferrer">Silverstone ML08zB-H</a></h2>
<p><img class="alignnone" src="https://www.technewstoday.com/wp-content/uploads/2018/12/Silverstone-ML08B-H-mITX-Case-with-Briefcase-Profile-1.jpg" alt="Best small portable pc case - Silverstone ML08zB-H" width="1200" height="630" /></p>
<p>The last case we’ll take a look at is the Silverstone ML08B-H. This <a href="https://www.technewstoday.com/best-micro-atx-cases/">micro atx case</a> is about the same shape and size as a briefcase. The case is designed to stand vertically and has feet at the bottom to keep it well balanced. A large handle at the top of the case makes it incredibly easy to take this computer with you on the go.</p>
<p>Due to the case’s extremely thin profile, it can only accommodate a slim power supply and a single dual slot expansion card, which your graphics card takes up. There are large vents at the top and bottom of the case for efficient airflow making the case cool despite its cramped interior.</p>
<p>The front of the case has a removable cover that protects the I/O which includes the standard 2 USB 3.0 ports as well as standard headphone and microphone jacks. If you want an incredibly portable case but don’t require tons of PCI-E slots or water cooling, then this case might be for you.</p>
<section class="prosCons2nd">
<section class="one-half">
<section class="pros-section2"><span class="section-title">Pros:</span></p>
<ul>
<li>Arguably the most compact and portable case on our list</li>
<li>Lightweight design</li>
<li>Strong handle and feet</li>
</ul>
</section>
</section>
<section class="one-half column-last">
<section class="cons-section2"><span class="section-title">Cons:</span></p>
<ul>
<li>Less than ideal cooling</li>
<li>Can only fit slim graphics cards, power supplies, and one 3.5&#8243; drive</li>
<li>Only compatible with mITX boards</li>
</ul>
</section>
</section>
</section>
<div class="yb">
<h4>Bottom Line</h4>
<ul>
<li>Very good case for someone who needs to take their case on the go</li>
<li>Not ideal for someone who needs  an ultra high-performance PC</li>
<li>Unique briefcase form factor</li>
</ul>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-cta'>
<a href='https://www.amazon.com/SilverStone-Technology-Mini-ITX-Computer-ML08B-H/dp/B0161UXWRA/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US' target='_blank' class='pct-checkprice-btn'>Check price on Amazon</a>
<img class='pct-amazon' src='https://www.technewstoday.com/wp-content/themes/tnt-child/images/amazon-minilogo.png'>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<h2>Portable Computer Case With Handle &#8211; BitFenix Prodigy M</h2>
<p><img class="alignnone" src="https://www.technewstoday.com/wp-content/uploads/2018/12/BitFenix-Prodigy-M-Micro-ATX-Case-Double-Handles.jpg" alt="Best compact gaming case - BitFenix Prodigy M" width="1200" height="630" /></p>
<p>The original Prodigy case from Bitfenix was designed to accommodate a mITX motherboard. While this design was popular in its own right, many people thought it was <a href="https://www.technewstoday.com/smallest-micro-atx-case/">unnecessarily large for a micro atx case</a>, so with the Prodigy M refresh of the design, BitFenix decided to design the case for the beefier mATX motherboard.</p>
<p>This expanded the PCI-E slots on the case from only one to four and also improved the overall compatibility of the case as a whole. One the front of the case is a drive bay for a cd reader or other accessories, while the power button and I/O are placed on the side of the case. As for I/O, the case includes 2 USB 3.0 ports as well as a standard headphone and microphone jack.</p>
<p>The case is incredibly compact which makes it easy to transport, and features two handles on the top made from BitFenix’s Fiver Flex plastic that gives the handles a soft feel. Its compact size is partly in thanks to an abnormal layout with the power supply being mounted at the front of the case and exhausting out the bottom. Despite this odd layout, the case does offer decent cooling with space for a 240mm radiator on the top of the case. There is also a spot for either a 120mm or 140mm fan in the back and just enough room for a full-size graphics card.</p>
<section class="prosCons2nd">
<section class="one-half">
<section class="pros-section2"><span class="section-title">Pros:</span></p>
<ul>
<li>Handles are made from a soft feel rubber making them easy to grip</li>
<li>Two handles offer better control than one</li>
<li>Available in lots of cool colors</li>
</ul>
</section>
</section>
<section class="one-half column-last">
<section class="cons-section2"><span class="section-title">Cons:</span></p>
<ul>
<li>Less than ideal airflow</li>
<li>Cannot fit full-size size graphics cards</li>
<li>Only has room for up to two expansion cards</li>
</ul>
</section>
</section>
</section>
<div class="yb">
<h4>Bottom Line</h4>
<ul>
<li>Good for those looking for a simple case</li>
<li>Can accept a wide range of radiators, but the airflow is not great</li>
<li>Comes in a ton of colors so you can make it look your own</li>
</ul>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-cta'>
<a href='https://www.amazon.com/dp/B00GVAQ2T6/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US' target='_blank' class='pct-checkprice-btn'>Check price on Amazon</a>
<img class='pct-amazon' src='https://www.technewstoday.com/wp-content/themes/tnt-child/images/amazon-minilogo.png'>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<h2>Mini ITX Case With Handle &#8211; Lian Li TU150WX</h2>
<p>Lian Li is one of the popular manufacturers, and their <a href="https://www.lian-li.com/pc-tu100/" target="_blank" rel="noopener noreferrer">TU100</a> and <a href="https://www.tweaktown.com/reviews/4436/lian_li_pc_tu200_mini_itx_chassis_review/index.html" target="_blank" rel="noopener noreferrer">TU200</a> were heavy-hitters on the bulky briefcase PC cases. Now they’ve put out the TU150 which, we daresay, executes the handle in the best possible way. It takes all the modern trends of brushed aluminum and tempered glass into a portable frame. And at a price of about $110, it is a product to consider when <a href="https://www.technewstoday.com/best-gaming-pc-build-under-1000/" target="_blank" rel="noopener noreferrer">building a portable gaming PC</a>.</p>
<p>The best thing about this case is that it makes a few compromises. It takes what’s good from a premium mid-tower and makes it portable. The design is sleek, and the aluminum keeps it from looking utilitarian. Lian Li has made this chassis very airflow-friendly. Even large CPU air coolers will fit, with the 165 mm clearance. Bumping up the front fan mount to allow for 140 mm fans would have been even better.</p>
<p><img class="aligncenter size-full wp-image-19921" src="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Mini-ITX-portable-gaming-case-Lian-Li-TU150WX.jpg" alt="Best Mini-ITX portable gaming case - Lian Li TU150WX" width="1200" height="630" srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Mini-ITX-portable-gaming-case-Lian-Li-TU150WX.jpg 1200w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Mini-ITX-portable-gaming-case-Lian-Li-TU150WX-300x158.jpg 300w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Mini-ITX-portable-gaming-case-Lian-Li-TU150WX-1024x538.jpg 1024w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Mini-ITX-portable-gaming-case-Lian-Li-TU150WX-768x403.jpg 768w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Mini-ITX-portable-gaming-case-Lian-Li-TU150WX-750x394.jpg 750w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Mini-ITX-portable-gaming-case-Lian-Li-TU150WX-1140x599.jpg 1140w" sizes="(max-width: 1200px) 100vw, 1200px" /></p>
<p>The negatives about this case revolve around its lack of SFF in its DNA. It is a small form factor case but yet manages to waste plenty of space here and there. Some SFF purists find it an insult for that matter. The liquid cooling support is also not the best, but this case was designed for air cooling, so we can forgive Lian Li on that front. Other minor issues include lack of bottom dust filter and wobbly power/reset buttons.</p>
<section class="prosCons2nd">
<section class="one-half">
<section class="pros-section2"><span class="section-title">Pros:</span></p>
<ul>
<li>Great build quality</li>
<li>Airflow-focused</li>
<li>Excellent mobility</li>
</ul>
</section>
</section>
<section class="one-half column-last">
<section class="cons-section2"><span class="section-title">Cons:</span></p>
<ul>
<li>Plenty of wasted space</li>
<li>PSU location is doubtful</li>
</ul>
</section>
</section>
</section>
<div class="yb"><strong>Bottom Line:</strong><br />
Tiny grievances aside, the Lian Li TU150 is an excellent portable case meant for air-cooled gaming rigs. The handle is the best part of this chassis.</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-cta'>
<a href='https://www.amazon.com/Razer-Coffee-8-Core-i9-9900K-3-6GHz/dp/B07R69SWHY/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US' target='_blank' class='pct-checkprice-btn'>Check price on Amazon</a>
<img class='pct-amazon' src='https://www.technewstoday.com/wp-content/themes/tnt-child/images/amazon-minilogo.png'>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<h2>Best Portable ATX Case &#8211; <a href="https://www.amazon.com/Cougar-Panzer-Max-Ultimate-Gaming/dp/B01HQHQF1W/ref=as_li_ss_tl?ie=UTF8&amp;amp;th=1&amp;amp;linkCode=ll1&amp;amp;tag=tntoday-20&amp;amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;amp;language=en_US" target="_blank" rel="noopener noreferrer">Panzer Max Ultimate</a></h2>
<p>As you read this review, a LAN party is about to go down somewhere, one is probably happening right now. Usually, gamers don’t mind showing up for a meet with a Full-Tower PC Case, especially when it’s a beautiful one. But the challenge is carrying such bulky unit around. That problem was adequately solved with the Cougar Panzer Max Ultimate.</p>
<p>Cougar isn’t the most popular PC Case manufacturer, but they certainly have one super case we couldn’t wait to lay our hands-on. Now let’s show what this case has to offer.</p>
<p><img class="alignnone" src="https://www.technewstoday.com/wp-content/uploads/2018/12/Cougar-Panzer-Max-Ultimate.jpg" alt="Best portable case for full atx - Panzer Max Ultimate" width="1200" height="630" /></p>
<p>The <strong>Panzer Max Ultimate </strong>comes in a jet black skin, looking all sturdy and sharp. The first thing that meets the eye when you unbox it is the two 3.5kg carry handles attached to the top of the case – that was what actually attracted us.</p>
<p>Looking closer, we see the case transparent glass window. That should be handy for the enthusiast that loves to show off. But not really ideal for a case that’s meant to be carried around.</p>
<p>The front panel is fully meshed, with a dust filter just behind it. You can mount two 120mm fans or 140mm fans on this case or fit two hefty 360mm radiators. In the compartments, there’s a perforated opening for external water-cooling hoses [you must break them open before use].</p>
<p>This case has two USB 2.0 and USB 3.0 ports. There’s a power button, a microphone/audio jack and a switch for the fan controller.</p>
<p>You can install a power supply unit at the bottom of the case. On the side of the case, there’s a hanger/hook for headphones.</p>
<p>In terms of expansion slots, the Panzer Max Ultimate has eight. It supports Extended-ATX motherboards and all the other smaller form factors. It can also house long GPUs.</p>
<section class="one-half">
<section class="pros-section2">
<section class="prosCons2nd">
<section class="one-half">
<section class="pros-section2"><span class="section-title">Pros:</span></p>
<ul>
<li>Superb design</li>
<li>Spacious and lots of expansion slots</li>
<li>Impressive cooling performance</li>
<li>Supports two massive radiators</li>
</ul>
</section>
</section>
<section class="one-half column-last">
<section class="cons-section2"><span class="section-title">Cons:</span></p>
<ul>
<li>Noisy</li>
<li>Uncompetitive price</li>
</ul>
</section>
</section>
</section>
</section>
</section>
<div class="yb">
<h4>Bottom Line</h4>
<ul>
<li>Massive and beautiful Full-Tower case with Carry Handle</li>
<li>Supports long graphics card and all types of motherboards</li>
<li>Features good water-cooling and airflow</li>
<li>Has air filter for the power supply</li>
<li>Lots of space and 8 expansion slots</li>
</ul>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-cta'>
<a href='https://www.amazon.com/Cougar-Panzer-Max-Ultimate-Gaming/dp/B01HQHQF1W/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US' target='_blank' class='pct-checkprice-btn'>Check price on Amazon</a>
<img class='pct-amazon' src='https://www.technewstoday.com/wp-content/themes/tnt-child/images/amazon-minilogo.png'>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<h2>Micro-ATX Case With Handle &#8211; IN WIN D-Frame</h2>
<p>InWin is never afraid to vary their designs greatly. Their followup to the X-Frame and H-Frame, both of which were successes, is the D-Frame. Inspired by the structure of premium motorcycles, this PC case is a showstopper. This is a huge chassis, dwarfing even full-tower ATX cases. It does have a mini version, however.</p>
<p>The D-Frame is a bold and risky product. You have to assemble it yourself. It has an exorbitant price. It ships in limited quantities. But a brave customer will find this a worthwhile challenge to own. And what better way to get familiar with your case than assemble it yourself. The build is extraordinary as well, with the pictures not really doing justice to how robust and flexible this case is. The new refresh, 2.0 also brings with it USB Gen 1 Type C, which is nice. You also get a SIII-1065W power supply with it, designed specifically with this chassis.</p>
<p><img class="aligncenter size-full wp-image-19924" src="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-case-for-airflow-IN-WIN-D-Frame.jpg" alt="Best case for airflow - IN WIN D-Frame" width="1200" height="630" srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-case-for-airflow-IN-WIN-D-Frame.jpg 1200w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-case-for-airflow-IN-WIN-D-Frame-300x158.jpg 300w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-case-for-airflow-IN-WIN-D-Frame-1024x538.jpg 1024w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-case-for-airflow-IN-WIN-D-Frame-768x403.jpg 768w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-case-for-airflow-IN-WIN-D-Frame-750x394.jpg 750w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-case-for-airflow-IN-WIN-D-Frame-1140x599.jpg 1140w" sizes="(max-width: 1200px) 100vw, 1200px" /></p>
<p>Going for an open air case is a risky choice, though. Understand that airflow is superior to any closed cases, but dust accumulation is insane. While it is mean to be lugged around and shown off in LAN parties, it is quite a heavy case. When accounting for the all the large components it has space for, carrying your rig around may become a two-man job. Despite the sheer size, only 4 drive bays are present, which is a letdown.</p>
<section class="prosCons2nd">
<section class="one-half">
<section class="pros-section2"><span class="section-title">Pros:</span></p>
<ul>
<li>Unmatched build quality and structure</li>
<li>Handle built into frame and versatile positioning</li>
<li>Aesthetics that set it apart from most PC cases</li>
</ul>
</section>
</section>
<section class="one-half column-last">
<section class="cons-section2"><span class="section-title">Cons:</span></p>
<ul>
<li>Really expensive</li>
<li>An unforgiving product</li>
</ul>
</section>
</section>
</section>
<div class="yb"><strong>Bottom Line:</strong><br />
If you don&#8217;t want your PC case to be simply a box, and want to turn custom PC building into an artform, take a look at the InWin D-Frame 2.0. This case will not let you down if you can afford it, although it might be difficult to lift it up.</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-cta'>
<a href='https://www.amazon.com/D-Frame-2-0-WH-BL-Motorcycle/dp/B06XGNLGJM/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US' target='_blank' class='pct-checkprice-btn'>Check price on Amazon</a>
<img class='pct-amazon' src='https://www.technewstoday.com/wp-content/themes/tnt-child/images/amazon-minilogo.png'>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<h2>Best PC Cases With Handle &#8211; MasterCase MC500Mt</h2>
<p>&nbsp;</p>
<p>Next on our list is an ATX case with a handle from Cooler Master. The mid-tower form factor is preferred by most PC builders as it offers a balance of space and portability. The interior is not overly cramped like some smaller form factors can be, but at the same time the case is not enormous like some <a href="https://www.technewstoday.com/best-atx-case/">full towers </a>can be.</p>
<p><img class="alignnone" src="https://www.technewstoday.com/wp-content/uploads/2018/12/MasterCase-MC500Mt-Beautiful-Mid-Tower-Case-Designed-for-Durability-and-Portability.jpg" alt="Best portable pc case for vr - MasterCase MC500Mt" width="1200" height="630" /></p>
<p>This case features an extremely sleek looking front panel with <a href="https://www.technewstoday.com/tempered-glass-pc-cases/">tempered glass windows</a> on both sides to give everyone around a great view of your hardware. The glass panels are held on with a special drop resistant brackets to give you extra assurance during transportation that the glass is securely in place and won’t be sliding or moving anywhere, even in the worst case scenario.</p>
<p>In addition to the top handle for easy carrying, the case also boasts a built-in graphics card holder that supports the weight of your graphics card. This prevents the card from putting stress on the PCI-E slot it’s in or even falling out of the slot which can happen when the computer is being carried.</p>
<p>The MC500Mt also utilizes <a href="http://freeform.coolermaster.com/" target="_blank" rel="noopener noreferrer">Cooler Master’s FreeForm modular system</a> that makes swapping out and customizing the panels on the outside of the case a breeze. Finally, this case also has the impressive front I/O that includes one USB 3.1 type-C, three USB 3.0 ports, and buttons to control both fan speed and the RGB inside the case.</p>
<section class="prosCons2nd">
<section class="one-half">
<section class="pros-section2"><span class="section-title">Pros:</span></p>
<ul>
<li>Can accommodate full-size ATX and even some eATX motherboards</li>
<li>Modular design allows for maximum customizability</li>
<li>Top of the line front I/O</li>
<li>Tons of drive bays (up to ten 2.5″ drives or eight 3.5″ drives)</li>
</ul>
</section>
</section>
<section class="one-half column-last">
<section class="cons-section2"><span class="section-title">Cons:</span></p>
<ul>
<li>Pretty large for a portable machine</li>
<li>Requires a special connector on the motherboard to run the I/O</li>
<li>Slightly on the heavy side</li>
</ul>
</section>
</section>
</section>
<div class="yb">
<h4>Bottom Line</h4>
<ul>
<li>Not the most portable option on our list</li>
<li>Very aesthetically pleasing case with good airflow</li>
<li>Capable of having most motherboard mounted in it along with tons of drives and expansion cards</li>
</ul>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-cta'>
<a href='https://www.amazon.com/Cooler-Master-MasterCase-ATX-Mid-Tower-Management/dp/B078BC3F22/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US' target='_blank' class='pct-checkprice-btn'>Check price on Amazon</a>
<img class='pct-amazon' src='https://www.technewstoday.com/wp-content/themes/tnt-child/images/amazon-minilogo.png'>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<h2>Portable Modular Computer Case &#8211; Cooler Master Q300P</h2>
<p>Cooler Master brought out two sibling cases a while back, priced at the budget segment. The Q300P is basically the cheaper Q300L with removable handles and acrylic paneling at the top and front. This handle design is innovative, also serving as case feet. At a price of around $85 and a duo of RGB fans plus a rear fan included, this takes our pick for the portable budget spot.</p>
<p><img class="aligncenter size-full wp-image-19922" src="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Budget-Case-with-a-Handle-Cooler-Master-Q300P.jpg" alt="Best Budget Case with a Handle - Cooler Master Q300P" width="1200" height="630" srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Budget-Case-with-a-Handle-Cooler-Master-Q300P.jpg 1200w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Budget-Case-with-a-Handle-Cooler-Master-Q300P-300x158.jpg 300w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Budget-Case-with-a-Handle-Cooler-Master-Q300P-1024x538.jpg 1024w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Budget-Case-with-a-Handle-Cooler-Master-Q300P-768x403.jpg 768w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Budget-Case-with-a-Handle-Cooler-Master-Q300P-750x394.jpg 750w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-Budget-Case-with-a-Handle-Cooler-Master-Q300P-1140x599.jpg 1140w" sizes="(max-width: 1200px) 100vw, 1200px" /></p>
<p>The Q300P is a larger chassis from our previous two picks, but you can still haul it around without much difficulty. From a distance, the design looks cool and trendy. But up close, you&#8217;ll realize the panels are not actually glass. The build process is quite easy, and the rear compartment leaves plenty of space to stuff cables. Aside from the fans, an RGB controller is included. But Cooler Master forgot to include instructions on how to use it. The I/O panel is interesting, as it has six locations it can be installed at.</p>
<p>Okay, now the bad stuff. The design, being plastic, is as icky from up close as you&#8217;d expect. The airflow is similar, and the fans up front especially fail to get much air circulation. The modular I/O panel is also more of a gimmick, and cable management is not made particularly easy.</p>
<section class="prosCons2nd">
<section class="one-half">
<section class="pros-section2"><span class="section-title">Pros:</span></p>
<ul>
<li>Excellent price</li>
<li>Innovative handle and I/O panel</li>
<li>RGB fans and controller included</li>
</ul>
</section>
</section>
<section class="one-half column-last">
<section class="cons-section2"><span class="section-title">Cons:</span></p>
<ul>
<li>Acrylic panels are iffy</li>
<li>No PSU shroud</li>
<li>Bad airflow</li>
</ul>
</section>
</section>
</section>
<div class="yb"><strong>Bottom Line:</strong><br />
There is no better deal for the price and what&#8217;s included in the package than the Cooler Master Q300P. You&#8217;ll have to sacrifice airflow and quality materials, though.</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-cta'>
<a href='https://www.amazon.com/Cooler-Master-Transparent-Adjustable-Controller/dp/B077XM396G/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US' target='_blank' class='pct-checkprice-btn'>Check price on Amazon</a>
<img class='pct-amazon' src='https://www.technewstoday.com/wp-content/themes/tnt-child/images/amazon-minilogo.png'>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<h2>Portable Desktop Gaming Case &#8211; ASUS TUF Gaming GT501</h2>
<p>If these tiny cases are just not doing it for you, take a look at the GT501. ASUS TUF Gaming is a series of rugged, military-looking products built with the same robustness. Compared to the rest of our lineup, this is a massive mid-tower. At a price of around $170, it is also the priciest. But its feature set seeks to justify the price tag.</p>
<p><img class="aligncenter size-full wp-image-19923" src="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-High-End-gaming-pc-case-ASUS-TUF-Gaming-GT501.jpg" alt="Best High-End gaming pc case - ASUS TUF Gaming GT501" width="1200" height="630" srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/Best-High-End-gaming-pc-case-ASUS-TUF-Gaming-GT501.jpg 1200w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-High-End-gaming-pc-case-ASUS-TUF-Gaming-GT501-300x158.jpg 300w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-High-End-gaming-pc-case-ASUS-TUF-Gaming-GT501-1024x538.jpg 1024w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-High-End-gaming-pc-case-ASUS-TUF-Gaming-GT501-768x403.jpg 768w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-High-End-gaming-pc-case-ASUS-TUF-Gaming-GT501-750x394.jpg 750w, https://www.technewstoday.com/wp-content/uploads/2020/07/Best-High-End-gaming-pc-case-ASUS-TUF-Gaming-GT501-1140x599.jpg 1140w" sizes="(max-width: 1200px) 100vw, 1200px" /></p>
<p>When going to LAN parties, this case will fulfill your every need. It looks terrific and is representative of the TUF branding. It has plenty of RGB at the front, and fan/radiator support is ample. You can fit ATX motherboards with ease, and installing other parts is a breeze. The build quality is excellent, and so is the airflow. All in all, this case is worthy of holding together a fully specced-out build.</p>
<p>There aren&#8217;t that many downsides to this case, except the price. One thing to consider is that at more than ten kilograms, this chassis not lightweight. Carrying it short distances is definitely possible, but don&#8217;t think it compares to the rest of our list and tiny mITX PCs. It does not.</p>
<section class="prosCons2nd">
<section class="one-half">
<section class="pros-section2"><span class="section-title">Pros:</span></p>
<ul>
<li>RGB fans and rugged aesthetic</li>
<li>Tough build quality</li>
<li>Great layout and exterior</li>
</ul>
</section>
</section>
<section class="one-half column-last">
<section class="cons-section2"><span class="section-title">Cons:</span></p>
<ul>
<li>Steep price</li>
<li>Huge size may hinder portability</li>
</ul>
</section>
</section>
</section>
<div class="yb"><strong>Bottom Line:</strong><br />
If you&#8217;re willing to reconsider what portability means, the TUF Gaming GT501 delivers on all fronts.</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-cta'>
<a href='https://www.amazon.com/ASUS-GT501-Mid-Tower-Motherboards-GRY/dp/B07L6CHS16/ref=as_li_ss_tl?ie=UTF8&amp;th=1&amp;linkCode=ll1&amp;tag=tntoday-20&amp;linkId=2e846302a7ce8542e64ad5037a38e254&amp;language=en_US' target='_blank' class='pct-checkprice-btn'>Check price on Amazon</a>
<img class='pct-amazon' src='https://www.technewstoday.com/wp-content/themes/tnt-child/images/amazon-minilogo.png'>
</div>
<div class='vc_vc_column vc_container-block vc_col-sm-4 column-pct-dummy'></div>
<h2>Before You Buy PC Case with a Handle What to Look for</h2>
<p>Before diving in, let us first consider why you would want a handle in the first place. And what being portable really means, and how it impacts other aspects of a case. We’ll consider the form factor, cooling, and other things to look out for.</p>
<h3>Form Factor</h3>
<p>When choosing a case, motherboard compatibility is at the forefront of specifications. What form factor should you use for portability?</p>
<p>If you have the money for it, <strong><a href="https://www.technewstoday.com/best-mini-itx-cases/" target="_blank" rel="noopener noreferrer">mini-ITX</a></strong> is the obvious recommendation. It populates most small form factor (SFF) custom PCs. This market segment revolves around making the most out of small dimensions and lightweight. The downside, compared to larger form factors, is mostly the number of peripherals you can connect. And of course, the price. You’re often paying a premium for the small well-engineered PCBs and cards that support the mITX standard.</p>
<p><a href="https://www.technewstoday.com/best-micro-atx-cases/" target="_blank" rel="noopener noreferrer"><strong>micro-ATX</strong></a> is another trendy recommendation. Like mITX, it used to be pricier than ATX. But recently, a budget market has sprung up around the specification. Now you can find plenty of cheap mATX motherboards and mini-towers to go with it. It is a sort of compromise between compactness and raw power. But there are some heavy-hitting mATX mobos, like the ASRock Steel Legend.</p>
<p>You rarely want to go <a href="https://www.technewstoday.com/smallest-atx-cases/" target="_blank" rel="noopener noreferrer">ATX</a> for portable PCs, because your whole build is going to be enlarged. E-ATX is even bigger and bulkier than ATX. However, some consumers will still favor the ATX standard due to the wide variety of options available. If you know what you’re doing, and make smart choices regarding the rest of your rig, you can still have a portable ATX system.</p>
<p>There are other form factors like DTX, mDTX, etc. that suit small builds, but you’ll be looking at a limited market. We recommend you stick with mITX or mATX unless you’re an expert.</p>
<h3>Cooling</h3>
<p>Keeping your components well under throttling temps is crucial to have excellent performance. Trying to carry around your PC does make some things interesting in this department.</p>
<p>In general, you want to go for <strong>air-cooled builds</strong>. Not because it gives better performance for the price (it does). Your heat sinks and fans will be relatively undamaged even after much shocks and vibration. This means you want to optimize for <a href="https://www.technewstoday.com/best-airflow-pc-cases/" target="_blank" rel="noopener noreferrer">airflow</a> and look for plenty of fan mounts. There is a problem, however. SFF PCs don’t have the space for installing many <a href="https://www.technewstoday.com/best-140mm-case-fans/" target="_blank" rel="noopener noreferrer">fans</a>, so you want to look for well-engineered frames that squeeze in as many mounts as possible. In this regard, the design of the chassis for airflow becomes even more critical.</p>
<p>Liquid-cooled builds are undoubtedly possible, but inadvisable. You can try installing <a href="https://www.technewstoday.com/best-120mm-aio/" target="_blank" rel="noopener noreferrer">AIOs</a>, and if you are very careful, then most likely, nothing terrible will happen. But if you are frequently moving, and the conditions are rough, your pipes or pumps may get damaged. Leaks are messy and dangerous. And don’t even think about installing custom loops, unless you are a pro eSports player whose rig receives the VIP treatment.</p>
<h3>Build and Handling</h3>
<p>The quality of materials and the frame structure of a PC case always matters. But if you’re moving your rig around, it matters even more. While you may get away with something like the <a href="https://www.in-win.com/en/gaming-chassis/alice/" target="_blank" rel="noopener noreferrer">InWin Alice</a> for a stationary setup, you better not use that case for a portable PC.</p>
<p>But heavily-built cases are not exactly portable, either. So you want a decent balance between <strong>robustness</strong> and <strong>lightness</strong>. Look at the materials and the net weight of the case. Especially for mITX cases, the weight should be minimal. The same goes for the volume. The exact shape of the chassis may be important as well. For instance, the <a href="https://nfc-systems.com/skyreach-4-mini" target="_blank" rel="noopener noreferrer">Skyreach 4 mini</a> fits into a backpack with ease. Although it fails to make our list due to availability issues and the distinct lack of a handle.</p>
<p>Regarding the handle, pay special attention to this part of the chassis. A plastic handle can work, but it needs to be thick and well-positioned. Handles from metal and other materials are usually better. If the handle is built into the frame itself, that’s the best kind you can find. As your build gets heavier, this section may become more prone to mechanical failure. You don’t want to drop and damage your rig, right?</p>
<h3>What about handle mods?</h3>
<p>Ahh, handle mods. At first glance, the DIY solution sounds excellent for portability. Choose whatever case strikes your fancy, then just install a grip later!</p>
<p>Unfortunately, there are many problems. We’re not saying DIY is always wrong. Building a custom PC is a do-it-yourself scenario. But, aftermarket fitting into a frame will never be as durable as something the manufacturer put in. If you weld and drill into the chassis, it may threaten the whole structure. Or make it look hideous. So often, you’re stuck between attaching a weak handle or ruining the looks of your case.</p>
<p>If you can live without a handle at all, that might be preferable to modding a handle into a case. For most of you, only looking to build a portable PC, buying a case with a handle is the better choice.</p>
<p><a name="FAQ"></a></p>
<h3>FAQ</h3>
<p><strong>What is the best motherboard form factor for an on the go PC?</strong></p>
<p>mITX will offer the greatest portability but will limit the kind of hardware you can use in the computer. ATX will be able to run the latest and greatest hardware but will be larger than other options. So the answer depends on whether you prioritize performance or portability.</p>
<p><a name="Conclusion"></a></p>
<h3>Final Thoughts</h3>
<p>If you&#8217;re looking for a case to take with you to LAN parties or on the go, then there are a number of cases available that feature a handle to help you travel easier. If you need tons of cooling and maximum durability, then the D-Frame Mini might be ideal for you. Its motorcycle steel design and shock absorbing feet offer maximum protection for your hardware.</p>
<p>If you think you need a full-size tower on the other hand, with ample expansion slots and tons of <a href="https://computer.howstuffworks.com/pci-express1.htm" target="_blank" rel="noopener noreferrer">PCI-E lanes</a> then the MasterCase MC500Mt might be a better choice. Its mid-tower profile can accommodate a wide variety of different boards. In addition, it boasts a unique modular design that offers tons of customizability.</p>
<p>Finally, if you&#8217;re looking for maximum portability then our recommendation is the Silverstone ML08B-H. It has a similar profile to a briefcase with a slim body and a large handle at the top. The only drawback is that its mITX motherboard can only accommodate a single expansion card.</p>
<p>No matter which one of the cases on our list you decide to get we are positive it will offer more portability than almost any of the other cases out there. As always, we love hearing from you guys, so if you&#8217;ve got questions or have bought one of these cases yourself, let us hear about it in the comments below.</p>
<p>&nbsp;</p>
<div class="jeg_post_tags"><span>Tags:</span> <a href="https://www.technewstoday.com/tag/computer-cases/" rel="tag">Computer Cases</a></div>
</div>
<div class="jeg_share_bottom_container"></div>
</div>
<div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"><div class="jeg_prevnext_post">
<a href="https://www.technewstoday.com/best-airflow-pc-cases/" class="post prev-post">
<span class="caption">Previous Post</span>
<h3 class="post-title">Best Airflow PC Cases – 2020 Recommendations</h3>
</a>
</div></div><div class="jnews_author_box_container"></div><div id="related-posts-single" class="jnews_related_post_container"></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container"> <div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/best-portable-pc-cases-with-handles/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.technewstoday.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='19823' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9587309516" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="165" /></p></form> </div>
</div> </div>
</div>
</div>
<div class="jeg_ad jeg_article jnews_article_bottom_ads">
<div class='ads-wrapper  '></div> </div>
</div>
</div>
</div>
</div>
<div id="post-body-class" class="post-template-default single single-post postid-19823 single-format-standard jeg_single_tpl_3 jeg_single_fullwidth jeg_single_narrow jnews jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"></div>
</div>
<div class="post-ajax-overlay">
<div class="preloader_type preloader_dot">
<div class="newsfeed_preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="newsfeed_preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="newsfeed_preloader jeg_preloader square">
<div class="jeg_square"><div class="jeg_square_inner"></div></div>
</div>
</div>
</div>
</div>
<div class="footer-holder" id="footer" data-id="footer">
<div class="jeg_footer jeg_footer_4 normal">
<div class="jeg_footer_container jeg_container">
<div class="jeg_footer_content">
<div class="container">
<div class="row">
<div class="jeg_footer_primary clearfix">
<div class="col-md-9 footer_column">
<ul class="jeg_menu_footer"><li id="menu-item-402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-402"><a href="https://www.technewstoday.com/">Home</a></li>
<li id="menu-item-11251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11251"><a href="https://www.technewstoday.com/about-us/">About Us</a></li>
<li id="menu-item-979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-979"><a href="https://www.technewstoday.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-401" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-401"><a href="https://www.technewstoday.com/affiliate-disclosure/">Affiliate Disclosure</a></li>
</ul> </div>
<div class="col-md-3 footer_column footer_right">
<div class="footer-text">
</div>
</div>
</div>
<div class="jeg_footer_secondary clearfix">
<div class="col-md-9 footer_column">
<p class="copyright"> © 2019 <a href="https://technewstoday.com" title="Tech News Today">Tech News Today</a> - Latest Tech News, Product Reviews &amp; Buyer's Guide </p>
</div>
<div class="col-md-3 footer_column footer_right">
<div class="jeg_social_icon_block socials_widget nobg">
<a href="https://www.facebook.com/TechNewsTodayTeam/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/TNT_dotcom" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.pinterest.com/TNT_dotcom/" target='_blank' class="jeg_pinterest"><i class="fa fa-pinterest"></i> </a> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div> </div>
<div class="jscroll-to-top">
<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
</div>
</div>

<div id="jeg_off_canvas" class="dark">
<a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
<div class="jeg_bg_overlay"></div>
<div class="jeg_mobile_wrapper">
<div class="nav_wrap">
<div class="item_main">

<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.technewstoday.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div><div class="jeg_aside_item">
<ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12076"><a href="https://www.technewstoday.com/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12077"><a href="https://www.technewstoday.com/reviews/">Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12078"><a href="https://www.technewstoday.com/how-to/">How To</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12079"><a href="#">Hardware</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12083"><a href="https://www.technewstoday.com/tag/cpus/">CPUs</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12080"><a href="https://www.technewstoday.com/tag/computer-cases/">Computer Cases</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12081"><a href="https://www.technewstoday.com/tag/motherboards/">Motherboards</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12082"><a href="https://www.technewstoday.com/tag/ram/">RAM</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12084"><a href="https://www.technewstoday.com/tag/gpu/">GPU</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12085"><a href="https://www.technewstoday.com/tag/psu/">PSU</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12086"><a href="https://www.technewstoday.com/tag/ssd/">SSD</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19246"><a href="https://www.technewstoday.com/tag/fans-cooling/">Fans &#038; Cooling</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12087"><a href="https://www.technewstoday.com/tag/gadgets/">Gadgets</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12088"><a href="https://www.technewstoday.com/tag/laptops/">Laptops</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12089"><a href="https://www.technewstoday.com/tag/gaming/">Gaming</a></li>
</ul></div> </div>
<div class="item_bottom">
<div class="jeg_aside_item socials_widget circle">
<a href="https://www.facebook.com/TechNewsTodayTeam/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/TNT_dotcom" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.pinterest.com/TNT_dotcom/" target='_blank' class="jeg_pinterest"><i class="fa fa-pinterest"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
<p>© 2019 <a href="https://technewstoday.com" title="Tech News Today">Tech News Today</a> - Latest Tech News, Product Reviews &amp; Buyer's Guide</p>
</div> </div>
</div> </div>
</div><script type="text/javascript">var jfla = ["view_counter"]</script><div id="selectShareContainer">
<div class="selectShare-inner">
<div class="select_share jeg_share_button">
<button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fwww.technewstoday.com%2Fbest-portable-pc-cases-with-handles%2F" data-image-url="" data-title="8+Best+Portable+PC+Cases+with+Handles+in+2020"><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fwww.technewstoday.com%2Fbest-portable-pc-cases-with-handles%2F" data-image-url="" data-title="8+Best+Portable+PC+Cases+with+Handles+in+2020"><i class="fa fa-twitter"></i></a>
</div>
<div class="selectShare-arrowClip">
<div class="selectShare-arrow"></div>
</div>
</div>
</div> <div style="display:none">
<div class="grofile-hash-map-25b6cfe7eee2110cb2bc994a0aecb48f">
</div>
</div>
<script>
                (function (i, s, o, g, r, a, m) {
                    i['GoogleAnalyticsObject'] = r;
                    i[r] = i[r] || function () {
                        (i[r].q = i[r].q || []).push(arguments)
                    }, i[r].l = 1 * new Date();
                    a = s.createElement(o),
                        m = s.getElementsByTagName(o)[0];
                    a.async = 1;
                    a.src = g;
                    m.parentNode.insertBefore(a, m)
                })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga');

                ga('create', 'UA-130686520-1', 'auto');
                ga('send', 'pageview');
            </script>
<div class="jeg_read_progress_wrapper"></div><script type='text/javascript'>
/* <![CDATA[ */
var jnewsoption = {"popup_script":"disable","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","lang":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"19823","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","site_slug":"\/","site_domain":"www.technewstoday.com"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-content/themes/tnt/assets/dist/frontend.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-content/plugins/jnews-split/assets/js/jquery.split.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202030'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.13-9993131'></script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.technewstoday.com/wp-content/themes/tnt/assets/js/html5shiv.min.js?ver=1.0.0'></script>
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-content/plugins/jnews-social-share/assets/js/plugin.js'></script>
<script type='text/javascript' src='https://www.technewstoday.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script async="async" type='text/javascript' src='https://www.technewstoday.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>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</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"8 Best Portable PC Cases with Handles in 2020","published":"2020-07-20 13:13:04","updated":"2020-07-20 15:06:04"}</script>
<script type='text/javascript' src='https://stats.wp.com/e-202030.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'151916501',post:'19823',tz:'0',srv:'www.technewstoday.com'} ]);
	_stq.push([ 'clickTrackerInit', '151916501', '19823' ]);
</script>
</body>
</html>
