<!doctype html> <!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]--> <!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]--> <!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]--> <!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]--> <!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]--><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.technewstoday.com/xmlrpc.php" /> <title>Ubisoft drops picture dropping massive hint on Far Cry 6</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://www.technewstoday.com/wp-content/cache/min/1/960dc21c26ef1d669ac55f7636dbf3a4.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="description" content="We are eagarly waiting for the release of Far Cry 6, as Ubisoft release drop massive teaser in form of image giving hints on the game." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Ubisoft drops picture dropping massive hint on Far Cry 6" /><meta property="og:description" content="We are eagarly waiting for the release of Far Cry 6, as Ubisoft release drop massive teaser in form of image giving hints on the game." /><meta property="og:url" content="https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/" /><meta property="og:site_name" content="Latest Tech News Today, Reviews &amp; Guides" /><meta property="article:published_time" content="2021-05-21T15:08:06+00:00" /><meta property="article:modified_time" content="2021-05-21T15:09:55+00:00" /><meta property="og:image" content="https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-drops-picture-dropping-massive-hint-on-Far-Cry-6.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="630" /><meta name="twitter:card" content="summary_large_image" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.technewstoday.com/#website","url":"https://www.technewstoday.com/","name":"Latest Tech News Today, Reviews &amp; Guides","description":"","potentialAction":[{"@type":"SearchAction","target":"https://www.technewstoday.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/#primaryimage","inLanguage":"en-US","url":"https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-drops-picture-dropping-massive-hint-on-Far-Cry-6.jpg","width":1200,"height":630,"caption":"Ubisoft drops picture dropping massive hint on Far Cry 6"},{"@type":"WebPage","@id":"https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/#webpage","url":"https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/","name":"Ubisoft drops picture dropping massive hint on Far Cry 6","isPartOf":{"@id":"https://www.technewstoday.com/#website"},"primaryImageOfPage":{"@id":"https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/#primaryimage"},"datePublished":"2021-05-21T15:08:06+00:00","dateModified":"2021-05-21T15:09:55+00:00","author":{"@id":"https://www.technewstoday.com/#/schema/person/9f7be094758b745381457e11e5aedac9"},"description":"We are eagarly waiting for the release of Far Cry 6, as Ubisoft release drop massive teaser in form of image giving hints on the game.","breadcrumb":{"@id":"https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/"]}]},{"@type":"BreadcrumbList","@id":"https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.technewstoday.com/","url":"https://www.technewstoday.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.technewstoday.com/news/","url":"https://www.technewstoday.com/news/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://www.technewstoday.com/tag/far-cry-6/","url":"https://www.technewstoday.com/tag/far-cry-6/","name":"Far Cry 6"}}]},{"@type":["Person"],"@id":"https://www.technewstoday.com/#/schema/person/9f7be094758b745381457e11e5aedac9","name":"Aashirbad","image":{"@type":"ImageObject","@id":"https://www.technewstoday.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/1956a8b86ea3a660ae0d08342fbdbea7?s=96&d=mm&r=g","caption":"Aashirbad"},"description":"I'm a computer enthusiasts and an audiophile. I play Counter-Strike : Global Offensive most of my times but make up time for Assassin's Creed Series. Always on a hunt for a good laptops like Razer Blade and Dell XPS. Don't like TOO MUCH RGB."}]}</script> <link rel='dns-prefetch' href='//secure.gravatar.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//v0.wordpress.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Latest Tech News Today, Reviews &amp; Guides &raquo; Feed" href="https://www.technewstoday.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Latest Tech News Today, Reviews &amp; Guides &raquo; Comments Feed" href="https://www.technewstoday.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Latest Tech News Today, Reviews &amp; Guides &raquo; Ubisoft drops picture dropping massive hint on Far Cry 6 Comments Feed" href="https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify}</style><link rel='preload' href='//fonts.googleapis.com/css?family=Khula%3Areguler%7COpen+Sans%3Aregular%2C600%2C700&#038;ver=1.0.0&#038;display=swap' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <!--[if lt IE 9]>
<link rel='stylesheet' id='vc_lte_ie9-css'  href='https://www.technewstoday.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.5' type='text/css' media='screen' />
<![endif]--><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.technewstoday.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style><style id='quads-styles-inline-css' type='text/css'>.quads-ad-label{font-size:12px;text-align:center;color:#333}</style> <script type='text/javascript' src='https://www.technewstoday.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <link rel='https://api.w.org/' href='https://www.technewstoday.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.technewstoday.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.technewstoday.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.6" /><link rel='shortlink' href='https://wp.me/pahqq9-7TU' /><link rel="alternate" type="application/json+oembed" href="https://www.technewstoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.technewstoday.com%2Fubisoft-drops-picture-dropping-massive-hint-on-far-cry-6%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.technewstoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.technewstoday.com%2Fubisoft-drops-picture-dropping-massive-hint-on-far-cry-6%2F&#038;format=xml" /> <script data-ad-client="ca-pub-9834707877558431" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><style type='text/css'>img#wpstats{display:none}</style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/www.technewstoday.com\/#organization","url":"https:\/\/www.technewstoday.com\/","name":"","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/www.facebook.com\/TechNewsTodayTeam\/","https:\/\/twitter.com\/TNT_dotcom","http:\/\/www.pinterest.com\/TNT_dotcom\/"]}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/www.technewstoday.com\/#website","url":"https:\/\/www.technewstoday.com\/","name":"","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.technewstoday.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <link rel="icon" href="https://www.technewstoday.com/wp-content/uploads/2020/07/cropped-fav-icon-512x512-1-2-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.technewstoday.com/wp-content/uploads/2020/07/cropped-fav-icon-512x512-1-2-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.technewstoday.com/wp-content/uploads/2020/07/cropped-fav-icon-512x512-1-2-180x180.png" /><meta name="msapplication-TileImage" content="https://www.technewstoday.com/wp-content/uploads/2020/07/cropped-fav-icon-512x512-1-2-270x270.png" /><style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail{display:none}</style><link rel="preload" type="text/css" href="https://www.technewstoday.com/?custom-css=5a4d14f4db" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" /> <noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body class="post-template-default single single-post postid-30374 single-format-standard jeg_single_tpl_1 jeg_single_fullwidth jeg_single_narrow jnews jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"><div class="jeg_ad jeg_ad_top jnews_header_top_ads"><div class='ads-wrapper '></div></div><div class="jeg_viewport"><div class="jeg_header_wrapper"><div class="jeg_header_instagram_wrapper"></div><div class="jeg_header normal"><div class="jeg_topbar jeg_container dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_grow"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item jeg_logo jeg_desktop_logo"><div class="site-title"> <a href="https://www.technewstoday.com/" style="padding: 0 0 0 0;"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" alt="Latest Tech News, Product Reviews &amp; Buyer&#039;s Guide" data-light-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-light-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" data-dark-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-dark-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" data-lazy-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png"><noscript><img class='jeg_logo_img' src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" alt="Latest Tech News, Product Reviews &amp; Buyer&#039;s Guide"data-light-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-light-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" data-dark-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-dark-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x"></noscript> </a></div></div><div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_4" data-animation="animate"><li id="menu-item-12076" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12076 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/news/">News</a></li><li id="menu-item-12077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12077 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/reviews/">Reviews</a></li><li id="menu-item-12078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12078 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/how-to/">How To</a></li><li id="menu-item-12079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12079 bgnav" data-item-row="default"><a href="#">Hardware</a><ul class="sub-menu"><li id="menu-item-12083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12083 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/cpus/">CPUs</a></li><li id="menu-item-12080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12080 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/computer-cases/">Computer Cases</a></li><li id="menu-item-12081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12081 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/motherboards/">Motherboards</a></li><li id="menu-item-12082" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12082 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/ram/">RAM</a></li><li id="menu-item-12084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12084 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/gpu/">GPU</a></li><li id="menu-item-12085" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12085 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/psu/">PSU</a></li><li id="menu-item-12086" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12086 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/ssd/">SSD</a></li><li id="menu-item-19246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19246 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/fans-cooling/">Fans &#038; Cooling</a></li></ul></li><li id="menu-item-12087" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12087 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/gadgets/">Gadgets</a></li><li id="menu-item-12088" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12088 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/laptops/">Laptops</a></li><li id="menu-item-12089" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12089 bgnav" data-item-row="default"><a href="https://www.technewstoday.com/tag/gaming/">Gaming</a></li></ul></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://www.technewstoday.com/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div><div class="jeg_separator separator5"></div><div class="jeg_nav_item socials_widget jeg_social_icon_block circle"> <a href="https://www.facebook.com/TechNewsTodayTeam/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/TNT_dotcom" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.pinterest.com/TNT_dotcom/" target='_blank' class="jeg_pinterest"><i class="fa fa-pinterest"></i> </a></div></div></div></div></div></div></div></div><div class="jeg_header_sticky"></div><div class="jeg_navbar_mobile_wrapper"><div class="jeg_navbar_mobile" data-mode="scroll"><div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_normal"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item"> <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_grow"><div class="item_wrap jeg_nav_aligncenter"><div class="jeg_nav_item jeg_mobile_logo"><div class="site-title"> <a href="https://www.technewstoday.com/"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" alt="Latest Tech News Today, Reviews &amp; Guides" data-light-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-light-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" data-dark-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-dark-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" data-lazy-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png"><noscript><img class='jeg_logo_img' src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" alt="Latest Tech News Today, Reviews &amp; Guides"data-light-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-light-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x" data-dark-src="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png" data-dark-srcset="https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 1x, https://www.technewstoday.com/wp-content/uploads/2020/07/tnt-logo2.png 2x"></noscript> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://www.technewstoday.com/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div></div></div></div></div></div></div><div class="sticky_blankspace" style="height: 60px;"></div></div><div class="post-wrapper"><div class="post-wrap"><div class="jeg_main jeg_sidebar_none"><div class="jeg_container"><div class="jeg_content jeg_singlepage"><div class="container"><div class="jeg_ad jeg_article jnews_article_top_ads"><div class='ads-wrapper '></div></div><div class="row"><div class="jeg_main_content col-md-no-sidebar-narrow"><div class="jeg_inner_content"><div class="jeg_breadcrumbs jeg_breadcrumb_container"><p id="breadcrumbs"><span><span><a href="https://www.technewstoday.com/">Home</a> » <span><a href="https://www.technewstoday.com/news/">News</a> » <span class="breadcrumb_last" aria-current="page">Far Cry 6</span></span></span></span></p></div><div class="entry-header"><h1 class="jeg_post_title">Ubisoft drops picture dropping massive hint on Far Cry 6</h1><div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1"><div class="meta_left"><div class="jeg_meta_author"> <img alt='Aashirbad' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/1956a8b86ea3a660ae0d08342fbdbea7?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' data-lazy-src="https://secure.gravatar.com/avatar/1956a8b86ea3a660ae0d08342fbdbea7?s=80&#038;d=mm&#038;r=g" /><noscript><img alt='Aashirbad' src='https://secure.gravatar.com/avatar/1956a8b86ea3a660ae0d08342fbdbea7?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1956a8b86ea3a660ae0d08342fbdbea7?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /></noscript> <span class="meta_text">by</span> <a href="https://www.technewstoday.com/author/aashirbad/">Aashirbad</a></div><div class="jeg_meta_date"> <a href="https://www.technewstoday.com/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/">May 21, 2021</a></div></div><div class="meta_right"></div></div></div></div><div class="jeg_featured featured_image"><div class="thumbnail-container animate-lazy" style="padding-bottom:50%"><img width="1140" height="570" src="https://www.technewstoday.com/wp-content/themes/tnt/assets/img/jeg-empty.png" class="attachment-jnews-1140x570 size-jnews-1140x570 lazyload wp-post-image" alt="Ubisoft drops picture dropping massive hint on Far Cry 6" data-src="https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-drops-picture-dropping-massive-hint-on-Far-Cry-6-1140x570.jpg" data-sizes="auto" data-srcset="https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-drops-picture-dropping-massive-hint-on-Far-Cry-6-1140x570.jpg 1140w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-drops-picture-dropping-massive-hint-on-Far-Cry-6-360x180.jpg 360w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-drops-picture-dropping-massive-hint-on-Far-Cry-6-750x375.jpg 750w" data-expand="700" /></div></div><div class="jeg_share_top_container"></div><div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper '></div></div><div class="entry-content with-share"><div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal"><div class="jeg_share_float_container"><div class="jeg_sharelist"> <a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.technewstoday.com%2Fubisoft-drops-picture-dropping-massive-hint-on-far-cry-6%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Ubisoft+drops+picture+dropping+massive+hint+on+Far+Cry+6&url=https%3A%2F%2Fwww.technewstoday.com%2Fubisoft-drops-picture-dropping-massive-hint-on-far-cry-6%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><div class="share-secondary"> <a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.technewstoday.com%2Fubisoft-drops-picture-dropping-massive-hint-on-far-cry-6%2F&title=Ubisoft+drops+picture+dropping+massive+hint+on+Far+Cry+6" rel='nofollow' class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fwww.technewstoday.com%2Fubisoft-drops-picture-dropping-massive-hint-on-far-cry-6%2F&media=https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-drops-picture-dropping-massive-hint-on-Far-Cry-6.jpg&description=Ubisoft+drops+picture+dropping+massive+hint+on+Far+Cry+6" rel='nofollow' class="jeg_btn-pinterest "><i class="fa fa-pinterest"></i></a></div> <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a></div></div></div><div class="content-inner "><p><span style="font-weight: 400">Ubisoft has garnered a lot of attention around its upcoming release, “Far Cry 6”. The Far Cry franchise has always been providing a thrill and certain level of satisfaction with its gameplay. The Far Cry 6 is the first title in the franchise debuting in the next-gen console. <a href="https://www.technewstoday.com/ubisoft-plus-is-replacing-uplay-plus-to-reach-stadia-and-luna/">Ubisoft</a> has dropped hints on the upcoming Far Cry 6. </span></p><figure id="attachment_30379" aria-describedby="caption-attachment-30379" style="width: 1200px" class="wp-caption aligncenter"><img class="wp-image-30379 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Ubisoft Leak Anton Castillo headroom" data-lazy-srcset="https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom.jpg 1200w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom-300x158.jpg 300w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom-1024x538.jpg 1024w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom-768x403.jpg 768w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom-750x394.jpg 750w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom-1140x599.jpg 1140w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom.jpg" /><noscript><img class="wp-image-30379 size-full" src="https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom.jpg" alt="Ubisoft Leak Anton Castillo headroom" srcset="https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom.jpg 1200w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom-300x158.jpg 300w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom-1024x538.jpg 1024w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom-768x403.jpg 768w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom-750x394.jpg 750w, https://www.technewstoday.com/wp-content/uploads/2021/05/Ubisoft-Leak-Anton-Castillo-headroom-1140x599.jpg 1140w" sizes="(max-width: 1200px) 100vw, 1200px" /></noscript><figcaption id="caption-attachment-30379" class="wp-caption-text">Source: Far Cry 6 Twitter</figcaption></figure><p><span style="font-weight: 400">Ubisoft uploaded an image for the upcoming Far Cry 6 release. The image reveals a portrait shot of Anton Castillo in the newspaper, the main antagonist of the gaming. The picture might look off as a simple picture to hype up the game. But there some information tying the picture to the game.   </span></p><p><span style="font-weight: 400">The picture shows the section of the newspaper with the portrait shot of Anton Castillo. The text in the newspaper informs Far Cry 6 is set in the city of Yara. The publication was released in November 2020 following the real-world time. According to the game trailer, the City of Yara is heavily influenced by real-life Cuba. </span></p><p><img class="size-full wp-image-30377 aligncenter" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Far Cry 6 banner" data-lazy-srcset="https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner.jpg 1200w, https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner-300x158.jpg 300w, https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner-1024x538.jpg 1024w, https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner-768x403.jpg 768w, https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner-750x394.jpg 750w, https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner-1140x599.jpg 1140w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner.jpg" /><noscript><img class="size-full wp-image-30377 aligncenter" src="https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner.jpg" alt="Far Cry 6 banner" srcset="https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner.jpg 1200w, https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner-300x158.jpg 300w, https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner-1024x538.jpg 1024w, https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner-768x403.jpg 768w, https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner-750x394.jpg 750w, https://www.technewstoday.com/wp-content/uploads/2021/05/Far-Cry6-banner-1140x599.jpg 1140w" sizes="(max-width: 1200px) 100vw, 1200px" /></noscript></p><p><span style="font-weight: 400">The newspaper titled “La Voz De Yara” translates to “Yara’s Voice.” Yara’s voice is the official newspaper of Yara is confirmed by the subtitle. The title gives off a strong vibe of resistance against the antagonist government, seeming run by resistance. There are rumors that Anton himself might be the owner of the publication. The headline “Hambre y agonia en el paraiso” translating to “Hunger and Agony in Paradise.” It bolsters the claim that Anton might be the head or owns the media outlet. </span></p><p><span style="font-weight: 400">The conflict between the resistance and government might be the main headline here. Anton refers to Yara as a Paradise; that is clear, according to the released trailer. </span></p><p><span style="font-weight: 400">Far Cry 6 is set in Yara and officially speaks the Spanish language. Anton is the main protagonist keeping the people and the media crumbled up in his fingers. Yara seems to have active journalists in the area. The journalists will be a great addition helping the players advance through the game and in side-quests. </span></p><p><span style="font-weight: 400">Ubisoft confirmed the release date for Far Cry 6 this year. The company did mention a February release date which got <a href="https://www.technewstoday.com/google-leaks-information-on-upcoming-ubisoft-title-on-stadia/">postponed</a>. Ubisoft revealed the game would release in April during its <a href="https://www.technewstoday.com/ubisoft-forward-highlights-prince-of-persia-remake/">earnings call</a>. But It is already May and Ubisoft still hasn’t confirmed any news on the release date. Far Cry 6 will be available on <a href="https://www.technewstoday.com/ebay-warns-its-customers-on-ps5-scammers-selling-photos-as-consoles/">PS5</a>, Xbox and <a href="https://www.technewstoday.com/best-gaming-pc-build-under-2000/">PC</a> during launch.                </span></p><div class="jeg_post_tags"><span>Tags:</span> <a href="https://www.technewstoday.com/tag/far-cry-6/" rel="tag">Far Cry 6</a><a href="https://www.technewstoday.com/tag/fps/" rel="tag">FPS</a><a href="https://www.technewstoday.com/tag/ubisoft/" rel="tag">Ubisoft</a></div></div><div class="jeg_share_bottom_container"></div></div><div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper '></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container"></div><div id="related-posts-single" class="jnews_related_post_container"><div class="jeg_postblock_9 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_30374_0_60a7cd46560e5 " data-unique="jnews_module_30374_0_60a7cd46560e5"><div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right"><h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3></div><div class="jeg_block_container"><div class="jeg_posts_wrap"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_md_1 post-30200 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-assassins-creed tag-google tag-stadia tag-ubisoft"><div class="jeg_thumb"> <a href="https://www.technewstoday.com/google-leaks-information-on-upcoming-ubisoft-title-on-stadia/"><div class="thumbnail-container animate-lazy size-500 "><img width="360" height="180" src="https://www.technewstoday.com/wp-content/themes/tnt/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="Google leaks information on upcoming Ubisoft Title on Stadia" data-src="https://www.technewstoday.com/wp-content/uploads/2021/04/Google-leaks-information-on-upcoming-Ubisoft-Title-on-Stadia--360x180.jpg" data-sizes="auto" data-srcset="https://www.technewstoday.com/wp-content/uploads/2021/04/Google-leaks-information-on-upcoming-Ubisoft-Title-on-Stadia--360x180.jpg 360w, https://www.technewstoday.com/wp-content/uploads/2021/04/Google-leaks-information-on-upcoming-Ubisoft-Title-on-Stadia--750x375.jpg 750w, https://www.technewstoday.com/wp-content/uploads/2021/04/Google-leaks-information-on-upcoming-Ubisoft-Title-on-Stadia--1140x570.jpg 1140w" data-expand="700" /></div></a><div class="jeg_post_category"> <span><a href="https://www.technewstoday.com/news/" class="category-news">News</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://www.technewstoday.com/google-leaks-information-on-upcoming-ubisoft-title-on-stadia/">Google leaks information on upcoming Ubisoft Title on Stadia</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.technewstoday.com/google-leaks-information-on-upcoming-ubisoft-title-on-stadia/"><i class="fa fa-clock-o"></i> April 30, 2021</a></div></div></div></article></div></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div></div> <script>var jnews_module_30374_0_60a7cd46560e5 = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"6","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":30374,"include_category":"","exclude_category":"","include_author":"","include_tag":"930,931,907","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"6","pagination_scroll_limit":3,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","excerpt_length":20,"paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_9"};</script> </div></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.technewstoday.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='30374' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="84e4a51219" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="106" /></p></form></div></div></div></div></div><div class="jeg_ad jeg_article jnews_article_bottom_ads"><div class='ads-wrapper '></div></div></div></div></div></div><div id="post-body-class" class="post-template-default single single-post postid-30374 single-format-standard jeg_single_tpl_1 jeg_single_fullwidth jeg_single_narrow jnews jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"></div></div><div class="post-ajax-overlay"><div class="preloader_type preloader_dot"><div class="newsfeed_preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="newsfeed_preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="newsfeed_preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="footer-holder" id="footer" data-id="footer"><div class="jeg_footer jeg_footer_4 normal"><div class="jeg_footer_container jeg_container"><div class="jeg_footer_content"><div class="container"><div class="row"><div class="jeg_footer_primary clearfix"><div class="col-md-9 footer_column"><ul class="jeg_menu_footer"><li id="menu-item-402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-402"><a href="https://www.technewstoday.com/">Home</a></li><li id="menu-item-11251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11251"><a href="https://www.technewstoday.com/about-us/">About Us</a></li><li id="menu-item-979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-979"><a href="https://www.technewstoday.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-401" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-401"><a href="https://www.technewstoday.com/affiliate-disclosure/">Affiliate Disclosure</a></li></ul></div><div class="col-md-3 footer_column footer_right"><div class="footer-text"></div></div></div><div class="jeg_footer_secondary clearfix"><div class="col-md-9 footer_column"><p class="copyright"> © 2019 <a href="https://www.technewstoday.com" title="Tech News Today">Tech News Today</a> - Latest Tech News, Product Reviews &amp; Buyer's Guide</p></div><div class="col-md-3 footer_column footer_right"><div class="jeg_social_icon_block socials_widget nobg"> <a href="https://www.facebook.com/TechNewsTodayTeam/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/TNT_dotcom" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.pinterest.com/TNT_dotcom/" target='_blank' class="jeg_pinterest"><i class="fa fa-pinterest"></i> </a></div></div></div></div></div></div></div></div></div><div class="jscroll-to-top"> <a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a></div></div><div id="jeg_off_canvas" class="dark"> <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a><div class="jeg_bg_overlay"></div><div class="jeg_mobile_wrapper"><div class="nav_wrap"><div class="item_main"><div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://www.technewstoday.com/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div><div class="jeg_aside_item"><ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12076"><a href="https://www.technewstoday.com/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12077"><a href="https://www.technewstoday.com/reviews/">Reviews</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12078"><a href="https://www.technewstoday.com/how-to/">How To</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12079"><a href="#">Hardware</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12083"><a href="https://www.technewstoday.com/tag/cpus/">CPUs</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12080"><a href="https://www.technewstoday.com/tag/computer-cases/">Computer Cases</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12081"><a href="https://www.technewstoday.com/tag/motherboards/">Motherboards</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12082"><a href="https://www.technewstoday.com/tag/ram/">RAM</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12084"><a href="https://www.technewstoday.com/tag/gpu/">GPU</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12085"><a href="https://www.technewstoday.com/tag/psu/">PSU</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12086"><a href="https://www.technewstoday.com/tag/ssd/">SSD</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19246"><a href="https://www.technewstoday.com/tag/fans-cooling/">Fans &#038; Cooling</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12087"><a href="https://www.technewstoday.com/tag/gadgets/">Gadgets</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12088"><a href="https://www.technewstoday.com/tag/laptops/">Laptops</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12089"><a href="https://www.technewstoday.com/tag/gaming/">Gaming</a></li></ul></div></div><div class="item_bottom"><div class="jeg_aside_item socials_widget circle"> <a href="https://www.facebook.com/TechNewsTodayTeam/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/TNT_dotcom" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.pinterest.com/TNT_dotcom/" target='_blank' class="jeg_pinterest"><i class="fa fa-pinterest"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright"><p>© 2019 <a href="https://www.technewstoday.com" title="Tech News Today">Tech News Today</a> - Latest Tech News, Product Reviews &amp; Buyer's Guide</p></div></div></div></div></div><div id="selectShareContainer"><div class="selectShare-inner"><div class="select_share jeg_share_button"> <button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fwww.technewstoday.com%2Fubisoft-drops-picture-dropping-massive-hint-on-far-cry-6%2F" data-image-url="" data-title="Ubisoft+drops+picture+dropping+massive+hint+on+Far+Cry+6"><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fwww.technewstoday.com%2Fubisoft-drops-picture-dropping-massive-hint-on-far-cry-6%2F" data-image-url="" data-title="Ubisoft+drops+picture+dropping+massive+hint+on+Far+Cry+6"><i class="fa fa-twitter"></i></a></div><div class="selectShare-arrowClip"><div class="selectShare-arrow"></div></div></div></div> <div style="display:none"><div class="grofile-hash-map-1956a8b86ea3a660ae0d08342fbdbea7"></div></div> <script>(function (i, s, o, g, r, a, m) {
                    i['GoogleAnalyticsObject'] = r;
                    i[r] = i[r] || function () {
                        (i[r].q = i[r].q || []).push(arguments)
                    }, i[r].l = 1 * new Date();
                    a = s.createElement(o),
                        m = s.getElementsByTagName(o)[0];
                    a.async = 1;
                    a.src = g;
                    m.parentNode.insertBefore(a, m)
                })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga');

                ga('create', 'UA-130686520-1', 'auto');
                ga('send', 'pageview');</script> <div class="jeg_read_progress_wrapper"></div><script type='text/javascript'>/* <![CDATA[ */ var jnewsoption = {"popup_script":"disable","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","lang":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"30374","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","site_slug":"\/","site_domain":"www.technewstoday.com"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var WPGroHo = {"my_hash":""}; /* ]]> */</script> <!--[if lt IE 9]>
<script type='text/javascript' src='https://www.technewstoday.com/wp-content/themes/tnt/assets/js/html5shiv.min.js?ver=1.0.0'></script>
<![endif]--> <script type='text/javascript'>/* <![CDATA[ */ var jnews_select_share = {"is_customize_preview":""}; /* ]]> */</script> <div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"article","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.technewstoday.com\/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6\/"},"dateCreated":"2021-05-21 15:08:06","datePublished":"2021-05-21 15:08:06","dateModified":"2021-05-21 15:09:55","url":"https:\/\/www.technewstoday.com\/ubisoft-drops-picture-dropping-massive-hint-on-far-cry-6\/","headline":"Ubisoft drops picture dropping massive hint on Far Cry 6","name":"Ubisoft drops picture dropping massive hint on Far Cry 6","articleBody":"<span style=\"font-weight: 400\">Ubisoft has garnered a lot of attention around its upcoming release, \u201cFar Cry 6\u201d. The Far Cry franchise has always been providing a thrill and certain level of satisfaction with its gameplay. The Far Cry 6 is the first title in the franchise debuting in the next-gen console. <a href=\"https:\/\/www.technewstoday.com\/ubisoft-plus-is-replacing-uplay-plus-to-reach-stadia-and-luna\/\">Ubisoft<\/a> has dropped hints on the upcoming Far Cry 6.\u00a0<\/span>\r\n\r\n[caption id=\"attachment_30379\" align=\"aligncenter\" width=\"1200\"]<img class=\"wp-image-30379 size-full\" src=\"https:\/\/www.technewstoday.com\/wp-content\/uploads\/2021\/05\/Ubisoft-Leak-Anton-Castillo-headroom.jpg\" alt=\"Ubisoft Leak Anton Castillo headroom\" \/> Source: Far Cry 6 Twitter[\/caption]\r\n\r\n<span style=\"font-weight: 400\">Ubisoft uploaded an image for the upcoming Far Cry 6 release. The image reveals a portrait shot of Anton Castillo in the newspaper, the main antagonist of the gaming. The picture might look off as a simple picture to hype up the game. But there some information tying the picture to the game.\u00a0\u00a0\u00a0<\/span>\r\n\r\n<span style=\"font-weight: 400\">The picture shows the section of the newspaper with the portrait shot of Anton Castillo. The text in the newspaper informs Far Cry 6 is set in the city of Yara. The publication was released in November 2020 following the real-world time. According to the game trailer, the City of Yara is heavily influenced by real-life Cuba.\u00a0<\/span>\r\n\r\n<img class=\"size-full wp-image-30377 aligncenter\" src=\"https:\/\/www.technewstoday.com\/wp-content\/uploads\/2021\/05\/Far-Cry6-banner.jpg\" alt=\"Far Cry 6 banner\" \/>\r\n\r\n<span style=\"font-weight: 400\">The newspaper titled \u201cLa Voz De Yara\u201d translates to \u201cYara\u2019s Voice.\u201d Yara\u2019s voice is the official newspaper of Yara is confirmed by the subtitle. The title gives off a strong vibe of resistance against the antagonist government, seeming run by resistance. There are rumors that Anton himself might be the owner of the publication. The headline \u201cHambre y agonia en el paraiso\u201d translating to \u201cHunger and Agony in Paradise.\u201d It bolsters the claim that Anton might be the head or owns the media outlet.\u00a0<\/span>\r\n\r\n<span style=\"font-weight: 400\">The conflict between the resistance and government might be the main headline here. Anton refers to Yara as a Paradise; that is clear, according to the released trailer.\u00a0<\/span>\r\n\r\n<span style=\"font-weight: 400\">Far Cry 6 is set in Yara and officially speaks the Spanish language. Anton is the main protagonist keeping the people and the media crumbled up in his fingers. Yara seems to have active journalists in the area. The journalists will be a great addition helping the players advance through the game and in side-quests.\u00a0<\/span>\r\n\r\n<span style=\"font-weight: 400\">Ubisoft confirmed the release date for Far Cry 6 this year. The company did mention a February release date which got <a href=\"https:\/\/www.technewstoday.com\/google-leaks-information-on-upcoming-ubisoft-title-on-stadia\/\">postponed<\/a>. Ubisoft revealed the game would release in April during its <a href=\"https:\/\/www.technewstoday.com\/ubisoft-forward-highlights-prince-of-persia-remake\/\">earnings call<\/a>. But It is already May and Ubisoft still hasn\u2019t confirmed any news on the release date. Far Cry 6 will be available on <a href=\"https:\/\/www.technewstoday.com\/ebay-warns-its-customers-on-ps5-scammers-selling-photos-as-consoles\/\">PS5<\/a>, Xbox and <a href=\"https:\/\/www.technewstoday.com\/best-gaming-pc-build-under-2000\/\">PC<\/a> during launch.\u00a0 \u00a0 \u00a0 \u00a0 \u00a0 \u00a0 \u00a0 \u00a0\u00a0<\/span>","author":{"@type":"Person","name":"Aashirbad","url":"https:\/\/www.technewstoday.com\/author\/aashirbad\/"},"articleSection":["News"],"image":{"@type":"ImageObject","url":"https:\/\/www.technewstoday.com\/wp-content\/uploads\/2021\/05\/Ubisoft-drops-picture-dropping-massive-hint-on-Far-Cry-6.jpg","width":1200,"height":630},"publisher":{"@type":"Organization","name":"","url":"https:\/\/www.technewstoday.com","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/www.facebook.com\/TechNewsTodayTeam\/","https:\/\/twitter.com\/TNT_dotcom","http:\/\/www.pinterest.com\/TNT_dotcom\/"]}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"Ubisoft drops picture dropping massive hint on Far Cry 6","published":"2021-05-21 15:08:06","updated":"2021-05-21 15:09:55"}</script> <script type='text/javascript' src='https://stats.wp.com/e-202120.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.8.2',blog:'151916501',post:'30374',tz:'0',srv:'www.technewstoday.com'} ]);
	_stq.push([ 'clickTrackerInit', '151916501', '30374' ]);</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.technewstoday.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>const wprRemoveCPCSS = () => { if( document.querySelector("link[data-rocket-async='style'][rel='preload']") ){ setTimeout(wprRemoveCPCSS, 200); }else{ $elem = document.getElementById( "rocket-critical-css" );if ( $elem ) {$elem.remove();} } }; if ( window.addEventListener ) { window.addEventListener( "load", wprRemoveCPCSS ); } else if ( window.attachEvent ) { window.attachEvent( "onload", wprRemoveCPCSS ); }</script><script src="https://www.technewstoday.com/wp-content/cache/min/1/4d98fa3a6bbd50a329398d7953d3c3da.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://www.technewstoday.com/wp-content/cache/min/1/960dc21c26ef1d669ac55f7636dbf3a4.css" data-minify="1" /><link rel='stylesheet' id='jeg_customizer_font-css' href='//fonts.googleapis.com/css?family=Khula%3Areguler%7COpen+Sans%3Aregular%2C600%2C700&#038;ver=1.0.0&#038;display=swap' type='text/css' media='all' /><link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://www.technewstoday.com/?custom-css=5a4d14f4db" /></noscript></body></html>
